Digitization Procedures

Acquiring and preparing the book

When the book has been physically acquired it is assigned a code and its pages are counted. Once this is done the information is added to the white board and the appropriate spreadsheet.

Naming convention example: LWGS0034.tif

  • (L) first character indicates that it's a local history. We've assigned (L, 1-9) for local histories
  • (WG) second & third character indicates the specific local history (00-ZZ) for a total of 1396 possible books
  • (S) fourth character indicates what the image is:
    • S = source image
    • E = edited image
    • A = 800 x 600 jpeg image
    • B = 1024 x 768 jpeg image
    • C = 10000 x 1000 jpeg image
    • Z = 200 x 200 jpeg image
  • (0034) characters five through eight indicates the amount of pages in each book (each book can have up to 10,000 pages)
  • possible file types:
    • .tif = archived master image (300dpi)
    • .jpg = web image (4 sizes)
    • .txt = text file of image (OCR)

Flatbed Scanning

  1. Power scanner on first, then computer.
  2. Using My Computer, or Windows Explorer, make a directory to save your source files to.
  3. Double click Irfanview on the desktop.
  4. Click on file then batch scanning.
  5. Enter the output file name (e.g. lwgs00), starting index (e.g. 00) and the destination directory (Be careful) will not warn you that you are about to save overtop of an existing image). Save the images as Tiff files, click OK.
  6. Once in the Twain Driver screen enter the following information:
    • Mode: Photo
    • Document: Platen Glass
    • Orientation: Standard 0 degrees (if rotation is needed, this will be done in Photoshop during Batch stage)
    • Size: Custom (therefore you must enter the Width & Length in the Scanning Area)
    • X & Y resolution: 300dpi
    • Colour mode: Greyscale
    • Gamma: Normal
    • Brightness: 0
    • Contrast: 0
    • Enable Start By Scanner (this allows you to use the green scan button on the scanner like a photocopier)
  7. Click the Scan button. You can now scan using the green button on the scanner.
  8. When you are finished scanning press the yellow button (on the scanner) to revert back to mouse control on Irfanview.
  9. Close Irfanview when finished.

Note: Unless the book you're scanning is so poor that you must make adjustments to the gamma, brightness and contrast during scanning, leave any changes to the Batch Edit stage (Photoshop).

Things to remember when scanning a book:

When scanning a book make sure it is lined up at the same mark for every scan. The top edge of the page should be flush with the edge of the scanner and at the same length marker (e.g. 9"x12") for every scan.

Press down on the spine firmly to get the best scan.

Scan the ENTIRE book. That includes the cover, blank pages, extra inserts, etc. The grayscale covers will be replaced later with colour covers but it's still important to scan them so we have an exact image count.

***Exception to the rule: if a book has pages that are only printed on one side then the blank pages on the opposite sides do not have to be scanned)***

IT IS VITAL THAT ALL THE PAGES SCANNED ARE AS STRAIGHT AS POSSIBLE, DO NOT RUSH (The straighter the pages, the more accurate the automated editing process will be and the less likely any manual editing will have to be done).

Scanning Colour Covers

  1. Open the HP Precision Scan program.
  2. Place the coloured cover in the center of the scanner, leaving the scanner top open. (This will create a black border around the book).
  3. Change the resolution in the scroll down menu from 200 dpi to 300 dpi. Then Preview the image.
  4. Change the Output type to "True Color".
  5. Make a Preview of the image by clicking the Preview button.
  6. Make any adjustments necessary using the various tools found under Tools in the tool bar. The cover scans should resemble the original book covers as much as possible
  7. Click Save and choose the folder to save the covers to. This will start the scan.
  8. Repeat steps 2-7 with the back cover.
  9. Open both images in Photoshop.
  10. Crop around the edge of each image leaving approximately 1cm (or less) of black border.
  11. In the main menu choose Image>Adjust >Colour Balance. Adjust the colour until it is as close to the colour of the cover of the book as you can get it without spending too much time on it (e.g. 10 minutes). Don't worry if the colour is not exactly the same, but make sure the colour of the front and back scanned images are the same.
  12. Double check that the image is 300 dpi by selecting Image>Image Size.
  13. During the QA stage, make sure to replace the greyscale covers with the colour covers.

Note: These steps apply for any colour image

Rename Scanned Files

  1. Once all the images of the book have been scanned, rename the files using NameWiz.
  2. In the column on the left, there is a file tree. Locate the files to rename in this column. By clicking on the Date bar, or Name bar, you will arrange the files in order.
  3. Enter the following information:
    • enable Alphanumeric, Increment & Numerical
    • - the Padding Mask should be the name of the file followed by an 's' for source and four zero's (ex. abcs0000)
    • Start with this should be zero
    • Increment by should be one
  4. Click preview. Scroll down to check the results, if everything is ok click apply.
  5. Scroll down again to make sure all the files were renamed properly (This will be indicated by an 'ok' beside each file. If 'error' appears beside any of the files click undo and try again.
  6. If everything renamed properly click reset and exit NameWiz.

Setting up the batch edit

Creating the action:

  1. Make the destination folders for the batch (left and right).
  2. Then open Photoshop. If the actions palette isn't open click Window>Show Actions.
  3. Create a new set of actions by clicking on the folder icon at the bottom of the actions palette. Enter the name of the book ID you're batching.
  4. Within your new set click the new action icon located at the bottom of the actions palette (it resembles a piece of paper with one corner folded over). Name the action after the book ID. Click the record button, you are now in record mode (indicated by the red circle at the bottom of the actions palette).
     
    Note: You can create a new set and action by clicking on the right arrow located at the top right hand corner of the actions palette as well.
  5. Click File>Open then double click an image that typically represents an average page for the book you're batch editing (If there's a page that contains text and pictures use that page as an example).
  6. Next, convert the image to grayscale by clicking Image>Mode>Grayscale. You will be prompted, 'discard color information'. Click Ok.
  7. Rotate the image if required. Click Image>Rotate>Canvas, then the amount of rotation.
     
    Remember: All the images will be rotated to the settings you choose. Also, if you rotate the image and it's not to your liking, stop recording the action, click undo (control>), start recording the action, then rotate the image again. Do not keep rotating the image without clicking undo because Photoshop will interpolate the image every time you rotate, thus degrading the image for every rotation you do.
  8. Adjust the levels if required (Zoom-in to give you an accurate view of the text and background). To adjust the levels, click Image>Adjust>Levels. The text should not be too thin or washed out. Be careful not to over saturate the black levels when there are pictures present.
  9. Sharpen the image if required. Click Filter>Sharpen>Unsharp Mask. NOTE: DO NOT OVERSHARPEN THE IMAGE! Generally on the Ricoh scanners no sharpening is required. If you are unsure if it needs sharpening don't sharpen the image. Any fine tuning to the sharpness of the images can be done at the web processing stage.
  10. If an edge is missing (When lining the book up to scan usually an edge will be missing) you can add an edge in your batch edit by expanding the canvas size. Make sure that the background color (in the tool>Click Image>Canvas Size then choose the amount and the direction to lengthen the appropriate edge. Make sure the newly created edge matches the other edges as closely as possible.
  11. Next, crop the left page of the image keeping in mind that every image will be cropped the same. Choose the crop tool>File>Save As then 'tiff' image. Save image into 'left' folder. Click the save button; the byte order should be PC and LZW compression should be checked.
  12. Click on the history palette and revert back to the action previous to your left crop. This restores the image just before you cropped the left side of the book. Go back to the actions palette. Select previous history state should appear in your actions sequence.
  13. Now crop the right side of the book and save the image in the 'right' folder that will store the right pages.
  14. The final step is to close the file. This is very important, if this step is not done, all the files will be left open and Photoshop will most likely crash.
  15. Stop recording the action by clicking on the square button located next to the circular record button at the bottom of the actions palette.

Running the batch

  1. Choose file>automate>batch.
  2. Choose the Set and Action you just created.
  3. Choose folder for the Source then click choose to locate your source images.
  4. Check the box for Override Action "Open" Commands. This overrides the open command that was recorded in your actions. Leave the 'include subdirectories' box unchecked.
  5. Choose folder for the destination. Choose an arbitrary folder (It doesn't really matter what folder you choose because the location is determined by the actions recorded).
     
    Note: Do Not check the box for Override Action "Save In" Commands. This forces the batch to use the save actions for your left and right folders you recorded in earlier.
  6. Choose Log Errors to File in the Errors field. Any errors that are encountered will be recorded to a text file you create without stopping the batch process. If any errors are logged to your text file a message will appear after processing alerting you to review the error log. Click the save as button to create the text file that will log the errors. If one was previously created, simply overwrite this text file.
  7. After double checking to make sure all the information is correct click OK to start the batch.

Note: Before renaming the files check your batch edit error log for mistakes. If there were errors they must be corrected before continuing on.


Next Page >>